Elite Dangerous - update 2.4 - The Return


#1

Might need to load this back up. Seems to have been an update where “mysterious aliens have just declared war”. There seems to be a lot of threads on reddit about this. From what ive just read on pc gamer, the ships are “organic in nature” and if you shot a piece of the ship and collect it, “The tissue sample is corrosive, and as soon as jcollasius scoops it up it begins eating away at his ship’s internal systems.”

Video of an encounter below.


#2

They had done a really nice build-up to the reveal of the Thargoids.

People were finding weird stuff and signals all over the place.

Somebody had figured out where to go at some point, chased an unidentified signal and got to its origin only to find nothing. He hung around a little bit hoping that something might happen after some time elapsed.

Suddenly a massive shadow fell across the cockpit and he looked up and a Thargoid (as in the video) just slowly drifted past his ship, not really doing anything and then boosted away. Whatever ship he was flying was fast and thought he could keep up, but the Thargoid just kept on speeding up and disappeared.

Since that event went public on YT, they’ve been building up to the full reveal and release of the Return of the Thargoids.

From the looks of things, they’ll kick your arse seven ways to Sunday if you try to solo them.


#3

REVIVAAAAAAAAAALLLLLLLLLLL!

O hai. I r just d/ling this - is on sale on Steam and looks to go well with my new toy.

Are there clans and shit?


#4

I think @adrock is the most informed on such matters!


#5

Awesome in VR.


#6

Fucking hell, Distant Worlds 2 event is starting in 2 weeks time.

It’s a 20-week long exploration event where solo players, teams, or entire wings head out in a huge convoy to explore a new system.

There’s also some special mining event, where EVERYONE playing E:D across all platforms can contribute towards supplying materials for the construction of a new space station within the new system as well. That’s PC, XBONE and PS4 players combined adding towards it.


#7

i thought the aim was to fly to beagle point (where the trolls wait in open play) and allow people to explore along the way, keeping track of folk using the new squadron system, and meet up each weekend at whatever waypoint for fun’n’games?

They’ve dropped the number of waypoints down to 15 so it shouldn’t take quite as long but keep in mind that 15 weeks is a one way trip during which you’ll just be flying, scanning, and maybe mining if you’re suitably equipped. it’s new, shiny, more engaged scanning and mining, but you’re leaving everything else behind in the meantime. I did road to riches in a week and a half and that was a lot of flying, this is doing that until mid-May. For the guys who are that into exploration it’s awesome, and i hope they manage to get more folks into it, but it’s a fairly large commitment. Though if the largest jump between waypoints is 8,000LY there may be folk who fly out and back again in the earlier weeks i guess. It also looks like they’re running a tour guide group to allow cmdrs to jump into other peoples ships on the journey rather than flying out there themselves (which is the most tempting option for me). This week though they’re taking folk through the engineer and guardian module upgrade paths in preparation, which is nice.

I think all community goals are across all platforms, or have been since i first did one. It looks like they’ve set 4 weeks aside for it, so i’d imagine 4 weeks of community events, 1 or 2 a week, but that far out it might only be mining and maybe combat goals.


#8

Absolute ragequit. 3 times.

Can’t get it to work with joystick, used VR and hand controllers to fly and get to a destination - couldn’t “land”.
Tried non-vr with joystick - nope. Tried non-vr with pad - have to use keyboard. How TF can vr be used, therefore?


#9

What joystick you using fella?

I remember with my X55 Rhino, I had a complete custom setup arrangement made. Still needed the keyboard for a few inputs because of menu options.


#10

thrustmaster t160000000000000000000000000

Got t.a.r.g.e.t. software running with custom key mapping - absolutely sure it’s not doing anything. Works ok with xbox controller, but as there’s so many things to do, not enough buttons even with a “press” on joystick to bijhnd 2 per button / stick.
Best result so far is with oculus controllers, but again, insufficient buttons.

I may have to shell out on the voiceattack software…


#11

I think n0tch, adrock and ronan will all give you good advice on that.


#12

I not in the right mood (lacking patience) to faff about setting it all up right now, so Ima go derp in tenkz ferrabit.

Ta, Caol. :smiley: :heart_eyes:


#13

i have all flight/ship control bound to joystick and throttle, along with menu navigation. In none-VR i use the keyboard for searching destinations; in VR i use bookmarks or voiceattack. voiceattack was a faff to setup initially, you’re best having a play with it and then add in individual functions for each thing you need and test them as you go.

My setup is terrible for the ground vehicles, though i can still control them well enough to complete the missions i’ve done and to explore alien shit on planet surfaces. I need to re-bind it to a controller i think as throttle+joystick is weird for a wheeled ground vehicle.

I also lack patience with things, i got stuff sorted by just doing it a bit at a time, and getting used to everything before going into VR helped.


#14

I have huge lack of patience…

I only have a joystick, so limited (a bit) to buttons. Gotta get the thing working right first, though… A suggestion from one of the VR pages was that USB may be having too much going through, so falling over. Didn’t think of that. My PC bits are arriving tomorrow, so I will test with new pc tomorrow. Depending on how the build goes will entirely factor on how much patience I will have to set it up! lol

Ta for teh input, Ad :slight_smile: