Is my GPU foobarred :(

Any advice would be appreciated guys…

PC would not power up, completely dead.
Opened case hoovered up dust and put back together
PC fires up to the Gigabyte splash screen showing the BIOS option keys and makes 1 short beep.
PC stays on splash screen, cannot access any options like entering the BIOS or Boot Order etc

Any ideas? I’ve removed all drives and got same result :cry:


Can you post your mobo model mate?

There is a beep code table in the mobo manuals usually that tells you what the beeps mean.

IM not sure Al, Gigabyte Ultra Durable is whats on the splash screen

Usually they print it between the PCI slots on the board in big white letters - can you see it from the side of your case?

I’ve found a generic guide - is the beep short or long?

short beep…peering in case as i type…

Ahhh, model is :- GA-Z77M-D3H

Something is seriously wrong with my work machine - every time I try to download the manual it hard crashes.

This is the link to the manual pdf - link.

Check for beep codes and see what 1 beep means mate.

Couple of other things you can try:

  • Disconnect all drives, your card and pop out your ram and try booting - start by putting your RAM back in one stick at a time (being sure to check what happens with each stick individually) and listening for the beeps (it should beep differently) and look out for it behaving differently
  • When you’ve done this do your GPU then your drives one by one looking and listening for the behaviour to change, stuff like getting further in the post or different beeps

After this all I could recommend is giving @DM501 and/or @Zorndar a shout for some help checking the voltage of the PSU or finding someone with a spare you could use.

Thanks mate appreciate it, i’ve dug up an oldPC so going to try the PSU in that PC.



You are pretty much out of luck with the beeps. One short beep is no problem is detected.
The link I posted earlier has the beeps
Just in case you want to check what the possibilities are, perhaps it is a long beep.

Continuous short beep :Power supply unit failed

Question is what the f is a continuous short beep?

How many RAM sticks do you have? IF more than one, take others out and replace one at a time. Try different slots to count out MB. Also, make sure you have HDDs plugged back in if removed. Also, try booting with out GFX in if you have on board. I used to know BIOS beeps too, can’t remember what they are now as they have changed.

4 RAM sticks Hammy, i’ll have a play about…

LOoks like my 1070 GTX could be the issue, going to find my old 8800 GTX and see if that works :frowning:

If the GPU is ok you might wanna try without any ram, should give you a different error code. Might give you pointers in the right direction.

PSU testing is typically a bit of a mixed bag. If its really broken you would probbaly notice without any tests. It can get a bit fiddly as one needs to run it under load and you would need to know what voltages are typical for your PSU. Measuring 12.5V for example on a 12V rail (not under load) is quite typical for some PSUs!

Failures are more difficult to spot even with the right equipment. Checking voltages typically only is worth if someone tempered with the cables, you smelled some famous blue smoke or a cable looks suspecious (burn marks).

Most of the time exchanging it for a spare PSU is a sufficient option. You said you found lots of dust, did you try blowing out the PSU? If the dust layer was old enough it can get “conductive” enough to cause problems.

BTW. thats a rather old motherboard, did you check the BIOS battery? You might need a new one!

1 Like

took the GPU out, plugged monitor into VGA port on MB, got past the Gigabyte splash screen then got startup error.
Fixed that and PC starts ok now,
I put the 1070 GTX back in and…it hangs on the Gigabyte splash screen :frowning:

Thank you all for your inputs guys, such a repository of Techie Knowledge :slight_smile:


Could still be the PSU is if the GFX is trying to pull too much power that the PSU can not handle.

1 Like

Especially if you only used onboard graphics. Try plugging in another gpu, if you have one!

Just to expand the point I was trying to make. I was trying to use an old 650w PSU on a build and that should have been enough for the kit I put in. It was not as the PSU was old and not 80+ anything, kept getting a power supply error when I tried to run any 3d apps(aka gpu started pulling power). My solution was to get an EVGA 80+ bronze 650W BQ series. This you can get from the EVGA site and at the moment it is going for 74 euro.
If you need modular the B3 model has that and is 5 euro more.

PC with its existing 750 watt PSU is now up and running with my old 8800 GT :slight_smile:

1 Like