Motherboard problems


#1

So, towards the end of 4 hours of editing 22,500 data points in excel, ALL of my USB ports shut down. All of them. Rear panel (only 2 of the 20 were working anyway), the PCI-E expansion card and the front ports.

Plugging in a device would bring a flicker of power, then nothing. Not even enough for the machine to recognise it.

Now, I’m guessing this is far from normal and possibly some ‘decay’ of a sort. 8 USB 3.0 ports on the rear panel haven’t worked since day 1.

I can’t really afford to lose access to the machine like that. Thankfully autorecovery saved the excel file and I only lost 10 minutes of work.

So, the question is; do I just get a new board (X99 socket 2011, not cheap) or do I get a NEW board and CPU?

I reckon it’s also time to get a new PSU.

Thoughts?


#2

my first thought would be to swap out the PSU, but if it was that you’d expect more than the USB to have an issue. If it was the pci bus again you’d expect more than the usb to be affected. if it was the usb controller, it wouldn’t be all the ports.

could grab a cheap 2011 xeon off ebay and try that in case it’s the CPU; the low end ones are cheap enough to hold their value a few weeks until you can rebay it.

There’s an Asus X99-E WS on amazon warehouse in vg condition for 220, but the board are tragically uncheap :confused:


#3

My guess is the chip for the USB is fucked if all of them don’t work. Weird though that the slot in card stopped too, that should have its own USB chip. Is the PCI-E expansion card an usb card though?

Other option, windows update! A while ago on my measurement pc a specific USB device stopped working, custom electronics, and the culprit was windows update. Turns out it updated the standard USB driver to something out of spec and it stopped that specific device being registered! So maybe have a look in the log files if there was a windows update!

It would be strange if its psu related, but maybe try it out to make sure? You can use a multimeter if there is a t least the 5V signal, if not maybe it is the PSU!

If you get new board and CPU maybe consider AMD threadripper? Cheaper than Intel for sure but might cause compatability issues! Just saying as x99 has a fairly hefty price tag, especialyl if you need to replace both CPU and motherboard.


#4

It was a weird one. I was in the middle of editing some cells in Excel and everything just stopped working at exactly the same time.

When I plugged out the mouse and tried it on various other ports, the lights would flash on for an instant, but that was all.
I did manage to get the mouse fully powered up through the USB-C port on the GPU, but the machine wasn’t detecting it, so there is certainly something with the USB controllers.

A restart later and they all started working again. It really is a bizarre issue and I have no idea what is the right way to go about it.

Socket 2011 is a hefty piece of kit and it would be a shame to change it out for such a large cost for such little gain. That being said though, motherboards for that socket are anything but cheap at the moment.


#5

yeah, you got me looking at it last night, and, well, i submitted my OT claim for the last 4 months and now plan to upgrade and maybe sell off my existing board (and chip i guess? it’s like the entry level for that socket anyway) to offset it. My only gripe is the 9900k is the obvious choice, but the 390 chipsets only support 4 ram slots across 2 channels, so i either need to drop down to 32GB ram or trade out my ram for new as well. It’d be ddr4 to ddr4 though, so potentially not the biggest cost in the world.

If i go socket 2066 there isn’t anything with the single core performance of the 9900 and there’re some hefty jumps in price. 9900 is 8c/16t mind, and a notable clock increase over the 5820 (4, 5Turbo, i think?).


#6

USB driver update? I know my board (MSI Z170A Gaming Pro Carbon s 1151) has just had updates for USBs especially USB 3/3.1 & Type C


#7

If all USB’s shut down on different controllers/cards etc. I’d suspect the USB driver/stack had a fart and popped everything.

I can’t say I have ever experienced USB issues to the extent that you have with your system but I’d have a quick look at the application and system event logs around the time it happend to see if the USB .dll’s etc. had a moment.

Could be power related but but a mouse is not exactly a power hog so its quite unlikely.


#8

The only USB devices plugged in were my mouse, keyboard, headphones and webcam. All turned off at the same time.

I’ll have to check the logs when I get home on Thursday. See what they show. No error messages turned up when it happened.

I think that the usb 3 driver just never installed from the get-go. I tried to install the standard usb drivers and controllers ages ago, but it could never install because of some missing software (hence the usb 3.0 ports never working).

I reckon I’ll just make do for a while as I’m a bit strapped for cash for quite some time. Fucking mortgage planning and solicitors!


#9

I might get shouted at for this but maybe something like drive booster I used it to get an old webcam working might of been just random luck though thought it worth a shout


#10

Any luck with this?


#11

Everything seems to be working fine again.

Haven’t had any issues since.

I can’t justify forking out 300 quid on a new board, so I think I’ll have to just be cautious and hold out until I can afford a full overhaul. Not that an X99 system really needs an overhaul mind…


#12

Just like that or after something you did.


#13

All I did was restart it when it happened? :confused:


#14

Weird :thinking:


#15

What make it your board @NaloaC ? If it’s MSi get Live Update 6, believe it or not this version actually works unlike the big pile of steaming poo that was Live Update 5. I did a shit load of mobo updates not so long back & everything actually installed & worked


#16

Cheers for that Rogue, but it’s an ASUS board.

Only update released for the BIOS addressed some security issue.

I’m starting to think that there are other issues with the board, namely the PCI-E lanes.

I’m not getting near as much performance out of the 2070 than what I was expecting. Sure, things run ok, but I should be getting more than 25-40 FPS in Division 2 if Vred is getting ~60 with everything on High.

Anthem should be getting a beating as well, it’s not.

War Thunder and the like are running nicely at ~55-60 FPS dialled up to Max, but that’s where the buck stops.

If I have no USB ports/drivers on the board (except for 2 x USB 2.0) then there is a big issue already. If I’m losing PCI-E lane bandwidth as well, then there is something seriously funky with it.

The 2 questions are;

  1. How the fuck do I check for throttling?

  2. Do I replace the board, or move to a new socket completely?


#17

Reseat CPU… Also PSU is a bit suspect now.
How about temps?
Also did you already reseat all the power cables?

My GPU was acting up and I had to reseat the power cables for that all ok since then.


#18

https://www.aida64.com/ I believe can do that.


#19

afterburner should be able to tell you too. Or any GPU monitoring thing if you can find out what the throttling temp or base frequency are.

I don’t remember if the pci-e lanes are fully implemented on the board chipset or just traces with the number active locked behind the CPU model or implemented in the CPU itself. I assume you’ve tried re-seating and checking the pins as this has been going a while.

Buy an X99 board, test, and re-sell? they’re not going to drop through the floor in price in the next week or two.


#20

GPUz displays the businterface for the GPU (PCIe actually used), otherwise there are plenty of monitoring softwares when it comes to temps, clockspeeds or ram usuage. CPUz is another one useful to check out. Both are free.

AIDA 64 is nice but for constant monitoring I like MSI Afterburner or NZXT CAM. The latter is fairly powerful and offers lots of tools whereas Afterburner is very basic and limitted to gpu only.